Tutorials

Definitions
Release Notes

Create a Model

Instructions: (Instructions will show here once you start the video)

Run a Model

Instructions: (Instructions will show here once you start the video)

Run an Experiment

Instructions: (Instructions will show here once you start the video)

Definitions

Model

VA Time Total: This is the average time that a product spends in the system undergoing a cycle time in a process.

NVA Time Total: This is the average time that a product spends in the system not undergoing a cycle time in a process. The VA Time Total also does not include the time waiting in the start (if applicable).

Frequency (Start Object): The time between products entering the system. This can be a value (e.g. 5), distribution (e.g. normal(10,2)), or list of observations (e.g. 6,11,20,7,7,9).

Amount (Start Object): The number of products that enter the system at each defined frequency. This can be a value (e.g. 5), distribution (e.g. normal(10,2)), or list of observations (e.g. 6,11,20,7,7,9).

maxAmount (Buffer and Process Object): The maximum number of objects that can be held within the object area at any given time. This should be a distinct value (e.g. 6).

startAmount (Buffer Object): The amount of product in this object when the model starts at time 0. This can be a value (e.g. 5), distribution (e.g. normal(10,2)), or list of observations (e.g. 6,11,20,7,7,9).

cycleTime (Process Object): The amount of time a product is delayed in a process object to account for a process occuring. This can be a value (e.g. 5), distribution (e.g. normal(10,2)), or list of observations (e.g. 6,11,20,7,7,9).

Processed (Object Statistic): The amount of product that has left this object.

Orders Processing (Object Statistic): This contains two numbers separated by a "/". The first number is the current number of orders being delayed by the object. The second number is the average number of orders that are delayed by the object at any given time from the start of the model to the current time.

Orders Waiting (Object Statistic): This contains two numbers separated by a "/". The first number is the current number of orders waiting for the next object to have availability. The second number is the average number of orders that are waiting for the next object to have availability at any given time from the start of the model to the current time.

Time Waiting (Buffer Object Statistic): The average amount of time a product waits in this buffer for the next step.

Processing (Process Object Statistic): The percent of available time a process is processing product.

Releasing (Process Object Statistic): The percent of available time a process is waiting for the next object to have availability so that it can send finished products to the next object.

Waiting (Process Object Statistic): The percent of available time a process is waiting for product to process from an upstream process.

Interface

Model Time: This contains two numbers separated by a "/". The first number is the current time of the simulation. The second number is the end time of the simulation.

Model Speed: The approximate multiple of speed that the model will attempt to run at if the user uses the play button to run the model (e.g. 5 would mean 5 simulation time units/second).

File -> New: The option to create a new model.

File -> Save: If this model was opened from a saved model, then this will save over the existing model. If this model was recently created, then this will do the same thing as "Save as New".

File -> Save as New: This will save the model under a model name under the current user.

File -> Save State: This will save the model in its current run. The simulation will remain with the model and will load with all the current statistics and run values. If this model was opened from a saved model, then this will save over the existing model. If this model was recently created, then this will do the same thing as "Save State as New".

File -> Save State as New: This will save the model in its current run. The simulation will remain with the model and will load with all the current statistics and run values.

File -> Export Screenshot: This create a screenshot of the model. Currently the arrows connecting the objects are not included in the screenshot (known issue).

File -> Exit to Profile: This will return the user to the user's profile page. It will not save the current model, so, if desired, that should be done previous to clicking this.

Tools -> None: This disables connection of objects using clicks on the objects.

Tools -> Connect Objects: The tool is used to connect objects in the model if "Auto Connect" is disabled. To connect objects this must be clicked. After enabling "Connect Objects", objects can be connected by clicking on the beginning object and then clicking on the ending object. An arrow will be displayed showing that the connection has been created.

Tools -> Disconnect Objects: The tool is used to disconnect objects in the model if "Auto Connect" is disabled. To disconnect objects this must be clicked. After enabling "Disconnect Objects", objects can be disconnected by clicking on the beginning object and then clicking on the ending object. The arrow representing the connection will be deleted once the disconnect occurs.

Tools -> Auto Connect: The "Auto Connect" tool is enabled by default. It automatically connects new objects to the last object created in the model.

Options -> Show Variables: The option to include the objects variables in the display.

Options -> Show Statistics: The option to include the objects statistics in the display.

Options -> Show Tooltips: The option to show tooltips to the user during model building.

Options -> Auto Size: Automatically size the objects to fit the information that is displayed within the object.

Options -> Auto Position: Automatically position the objects with relation to their flow in the system.

Options -> Resize All: Size the objects to fit the information that is displayed within the object.

Options -> Reposition All: Position the objects with relation to their flow in the system.

View -> Reset View: Change the zoom and position of the model view to the original presets.

View -> Process View: The original process map view of the system.

View -> Tree View: A tree view of the data structure of the model.

View -> Experiment View: The view used to create, edit, and run various scenarios and replications of the model.


Release Notes

Release 2017.12.23: Added model storage capability.

Release 2017.07.20: Enhanced the GUI.

Release 2016.04.28: Added code support for optimizer, GUI forthcoming.

Release 2016.02.20: Added code support for scheduled downtimes using mtbf and mttr, GUI forthcoming.

Release 2016.12.13: Added switch for user to define if an object is value add to the system.

Release 2016.11.12: Added split and merge objects.

Release 2016.10.05: Improved the experiment feature to allow for more scenarios and more data collection.

Release 2016.10.04: Built stored_stats feature that saves stats in the object each time the calculation is updated.

Release 2016.10.01: Initial public release of OPS.

Release 2016.09.20: Added auto-size and auto-position features.

Release 2016.09.17: Added auto-connect feature.

Release 2016.09.15: Added screenshot feature.

Release 2016.09.14: Added garbageCollection. Garbage collection enables a mode that does not store modelLog or movement history. This feature decreases the memory requirement.

Release 2016.09.13: Created web tools for sharing models.

Release 2016.09.12: Created web tools for managing models.

© Descreye Solutions, 2020